You must register to have access to the complete forum.

Author Topic: Icarus 1.6 crash in MuLab  (Read 492 times)

JoergB

  • Newbie
  • *
  • Posts: 3
Icarus 1.6 crash in MuLab
« on: September 07, 2019, 05:08:38 PM »
Hello everyone,

does anyone work with MuLab 8? Icarus crashes, when I start the wavetable editor a second time. Same happens, when I exit the wavetable editor and then choose Init patch. Strange...

Thanks very much!
Joerg

Win10Pro x64
Icarus 1.6 x64 / VST 2.4
Mulab 8.1.5 x64
« Last Edit: September 07, 2019, 05:18:30 PM by JoergB »

Markus Krause

  • Tone2.com audiosoftware
  • Administrator
  • Hero Member
  • *****
  • Posts: 3083
    • Tone2.com audiosoftware
Re: Icarus 1.6 crash in MuLab
« Reply #1 on: September 09, 2019, 07:19:44 AM »
Hello Joerg,

i examined and fixed this in the code some weeks ago. It can occasionally happen in a hand full of of hosts if you:

1) Open the wavetable editor
2) Close / Hide the GUI of the plugin
3) Open the GUI of the plugin again
4) Open the wavetable editor again

It does not happen if you:

1) Open the wavetable editor
2) Close the wavetable editor
3) Close / Hide  the GUI of the plugin
4) Open the GUI of the plugin again
5) Open the wavetable editor again

Solution:
Install the next update

Workaround 1:
Use another host or the standalone

Workaround 2:
Close the wavetable editor before you minimize the GUI

Best Regards,
Markus

JoergB

  • Newbie
  • *
  • Posts: 3
Re: Icarus 1.6 crash in MuLab
« Reply #2 on: September 09, 2019, 01:57:33 PM »
Thanks very much Markus :) Yes, the standalone version works fine...

Joerg